MGB-IPH
Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Flow Accumulation com todos os valores de atributo iguais a 0 (zero)

Ir em baixo

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Empty Flow Accumulation com todos os valores de atributo iguais a 0 (zero)

Mensagem  altairmaciel em Ter Jul 16, 2019 12:37 pm

Saudações!

Estou tentando modelar uma bacia através do MGB 2018 utilizando o IPH-Hydro Tools no QGis (tanto na versão 2.18.20 como na versão 2.18.28). Durante a etapa de discretização da bacia hidrográfica, ao utilizar a ferramenta de acumulação de fluxos (Flow Accumulation), o QGis retorna um produto raster com todos os valores de atributo iguais a 0 (zero).

Já tentei pesquisar em diversos fóruns qual seria a causa desse problema mas não encontrei solução.

Converti o mosaico de trabalho (MNT) para ASCII utilizando o IPH-Hydro Tools (Conversion QGIS ASCII - IPHHT ASCII no menu Managemente Tools), visto que o IPH-Hydro Tools não aceita o formato ASCII gerado pelo QGis.  

Alguns fóruns que tratam de SIG em geral, informaram que o problema poderia estar no produto necessário para a geração da acumulação de fluxos (Flow Accumulation), ou seja, o direção de fluxos (Flow Direction). No entanto, aparentemente, não identifiquei problema neste último.

O manual de exemplo de aplicação do MGB 2018 utilizando o QGis recomenda salvar o produto direção de fluxos (Flow Direction) somente no formato IRST. No entanto, salvei também no formato .asc para visualizá-lo e verificar se o produto direção de fluxos (Flow Direction) estava sendo gerado pelo IPH-Hydro Tools com erro/problema. Aparentemente, não há nada de errado com o produto direção de fluxos (Flow Direction). Os valores associados a esse produto estão conforme esperado, apresentando somente os valores 1, 2, 4, 8, 16, 32, 64 e 128.

Sendo assim, não sei qual a razão do IPH-Hydro Tools no QGis gerar o acumulação de fluxos (Flow Accumulation) com todos os valores de atributo iguais a 0 (zero).

Se alguém tiver passado por esse problema e puder me ajudar a encontrar a solução, ficarei muito agradecido.

Cordiais saudações!

altairmaciel

Mensagens : 2
Data de inscrição : 16/07/2019

Voltar ao Topo Ir em baixo

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Empty Re: Flow Accumulation com todos os valores de atributo iguais a 0 (zero)

Mensagem  Aline Meyer Oliveira em Qua Jul 17, 2019 9:15 am

Olá Altair,

Suspeito que possa ser apenas um problema na visualização do raster.
Sugiro que você clique com o botão direito na camada do Flow Accumulation, e abra as "Propriedades" do raster.
Selecione "estender para MinMax", e modifique os valores "Min" e "Max" para melhorar a visualização.

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Forumf10

Caso não seja esse o problema, avise aqui, e procuramos por outras alternativas para solucionar.

Aline Meyer Oliveira

Mensagens : 84
Data de inscrição : 25/10/2017

Voltar ao Topo Ir em baixo

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Empty Re: Flow Accumulation com todos os valores de atributo iguais a 0 (zero)

Mensagem  altairmaciel em Sex Jul 19, 2019 10:49 am

Olá, Aline Meyer,

muito obrigado pela resposta! Realmente, era um problema de visualização. Os valores limites para visualização do raster estavam definidos para 0 (zero) tanto no mínimo quanto no máximo. Dessa forma, não tinha como visualizar nada.

Alterei a opção, selecionando "estender para MinMax" como você indicou e deu certo. Agora o raster está apresentando um gradiente de cores variando entre os valores mínimo e máximo.

Mais uma vez, muito obrigado, Aline Meyer!

Cordiais saudações.

altairmaciel

Mensagens : 2
Data de inscrição : 16/07/2019

Voltar ao Topo Ir em baixo

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Empty Problema parecido

Mensagem  André Campos em Qua Jul 24, 2019 3:30 pm

Olá, pessoal! Espero que estejam bem!

Passo por um problema semelhante: estou seguindo o tutorial para me familiarizar com o MGB.
Ao executar os processamentos, os rasters gerados possuem valores coerentes, só que não estão aparecendo no QGIS.
Não é nenhum problema de Zoom Extend aparentemente, pois para qualquer nível de zoom o raster não é mostrado.
Todos os rasters estão georeferenciados ao WGS84.
Também já tentei a solução deste post, mas não solucionou meu problema.
O interessante é que na Thumbnail quando abro as propriedades (como dá pra verificar na imagem) o raster aparece.

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Erro_d11


Alguém teria alguma ideia do que pode ser?

Talvez possa servir de informação: Para executar o "Extract by Polygon", precisei fazer de forma diferente do tutorial. Essa ferramenta do IPH HydroTools estava gerando um raster sem valores numéricos (NaN) para mim. Logo, o que eu acabei fazendo foi:
i) recortar pelo próprio QGIS, gerando um .tiff;
ii) transformando o .tiff em .asc;
iii) usando a ferramenta "Conversion QGIS ASCII - IPHHT ASCII" para poder iniciar os processamentos com o recorte da área de interesse.

Agradeço desde já se alguém puder colaborar!
André Campos.
André Campos
André Campos

Mensagens : 11
Data de inscrição : 24/07/2019
Idade : 27
Localização : Curitiba

Voltar ao Topo Ir em baixo

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Empty Re: Flow Accumulation com todos os valores de atributo iguais a 0 (zero)

Mensagem  Aline Meyer Oliveira em Qua Jul 24, 2019 3:37 pm

Olá André,

Isso nunca me aconteceu. Muito estranho. Você já tentou fechar e abrir o QGIS novamente?
Em um arquivo novo, tente abrir apenas este raster que deseja visualizar.

Você tem algum outro software de geoprocessamento instalado? Podes verificar se o raster abre no mapwindow, ou no arcgis.

Podes também me enviar o arquivo raster por e-mail para que eu tente diagnosticar o problema aqui: alinemey@gmail.com

Aline Meyer Oliveira

Mensagens : 84
Data de inscrição : 25/10/2017

Voltar ao Topo Ir em baixo

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Empty Re: Flow Accumulation com todos os valores de atributo iguais a 0 (zero)

Mensagem  André Campos em Qui Jul 25, 2019 10:02 am

Aline, descobri o problema!! Era o Cell Size!

Acho que nos processamentos, alguma questão de "." e "," foi confundida e o cell size dos rasters estavam todos da ordem de 10^8.
Editei o arquivo no bloco de notas pra mesma ordem do SRTM e deu certo, apareceram!

Unica coisa que estou enfrentando problemas mesmo é o Extract do IPH Hydro Tools, que realmente não está gerando arquivos!

Mas muito obrigado pela disposição em ajudar!
André Campos
André Campos

Mensagens : 11
Data de inscrição : 24/07/2019
Idade : 27
Localização : Curitiba

Voltar ao Topo Ir em baixo

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Empty Re: Flow Accumulation com todos os valores de atributo iguais a 0 (zero)

Mensagem  Aline Meyer Oliveira em Qui Jul 25, 2019 10:10 am

Olá, que bom que conseguiu descobrir!

Você está usando o Extract by Polygon, ou o Extract raster by raster?

Qual é o erro?

Aline Meyer Oliveira

Mensagens : 84
Data de inscrição : 25/10/2017

Voltar ao Topo Ir em baixo

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Empty Re: Flow Accumulation com todos os valores de atributo iguais a 0 (zero)

Mensagem  André Campos em Qui Jul 25, 2019 10:44 am

Estou usando o Extract by Polygon!

Quando o raster é gerado, fica assim:

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Erro_e10

Note que após o processamento, os valores do raster ficam estranhos. Acredito que seja relacionado realmente a questão de "." e ",". Ainda tô investigando se consigo alguma solução pra isso.
André Campos
André Campos

Mensagens : 11
Data de inscrição : 24/07/2019
Idade : 27
Localização : Curitiba

Voltar ao Topo Ir em baixo

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Empty Re: Flow Accumulation com todos os valores de atributo iguais a 0 (zero)

Mensagem  Aline Meyer Oliveira em Qui Jul 25, 2019 11:14 am

André,

Sugiro que vá no Painel de Controle > Relógio e Região > Região > Configurações Adicionais.

O "símbolo decimal" deve ser ponto (.)

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Captur10

Aline Meyer Oliveira

Mensagens : 84
Data de inscrição : 25/10/2017

Voltar ao Topo Ir em baixo

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Empty Re: Flow Accumulation com todos os valores de atributo iguais a 0 (zero)

Mensagem  André Campos em Qui Jul 25, 2019 11:26 am

Era exatamente isso, Aline!
Eu tava procurando no próprio QGIS se tinha alguma configuração só pro software, mas mudar o separador decimal do sistema funcionou também!
Usei o Extract by Polygon agora e deu super certo!

Grato pela colaboração!
André Campos
André Campos

Mensagens : 11
Data de inscrição : 24/07/2019
Idade : 27
Localização : Curitiba

Voltar ao Topo Ir em baixo

Flow Accumulation com todos os valores de atributo iguais a 0 (zero) Empty Re: Flow Accumulation com todos os valores de atributo iguais a 0 (zero)

Mensagem  Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum