MGB-IPH
Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

Problemas com a criação das Classes de Respostas Hidrológicas

Ir em baixo

Problemas com a criação das Classes de Respostas Hidrológicas Empty Problemas com a criação das Classes de Respostas Hidrológicas

Mensagem  Isabela Rotondaro em Qui Set 10, 2020 2:54 pm

Boa tarde!

Estou utilizando a "Alternativa 02: Utilizando o mapa de URH's da América do Sul" para gerar as classes de respostas hidrológicas de meu projeto. Dessa forma, eu realizo todo o procedimento, conforme orientado no manual. Porém o arquivo gerado (output raster file), através da ferramenta "Extract Raster By Polygon", sai em branco. Quando eu importo ele para dentro do programa, não aparece nenhum desenho. Já tentei mudar a referência, mas não adianta. O arquivo não aparece. Como posso proceder nesse caso? Posso dar prosseguimento no trabalho, mesmo com o arquivo em branco?

No caso, eu estou utilizando um MDE com resolução de 30,0 metros. No manual é utilizado um de 90,0 metros. Isso influencia em algo?

Até este item, todos os procedimentos foram concluídos com sucesso.

Isabela Rotondaro

Mensagens : 4
Data de inscrição : 17/08/2020

Voltar ao Topo Ir em baixo

Problemas com a criação das Classes de Respostas Hidrológicas Empty Re: Problemas com a criação das Classes de Respostas Hidrológicas

Mensagem  Gustavo Gabbardo dos Reis em Ter Set 15, 2020 9:46 am

Olá Isabela,

Sim você pode utilizar um MDE de maior resolução como dado de entrada no modelo, aparentemente não é essa a causa do seu problema.
Quando você diz que o arquivo está em branco, você quer dizer que ele não aparece no ambiente SIG, porém ele consta normalmente no seu diretório e você abrindo o arquivo com um bloco de notas por exemplo consegue perceber que ele está devidamente preenchido com valores numéricos (-9999 para células vazias e valores de 1 a 9 conforme a classe de resposta hidrológica de cada célula) ?

Caso positivo, acredito que seja apenas algum erro de representação do arquivo matricial no QGIS. Talvez alterando os valores máx e mín no campo de simbologia do programa ele possa aparecer na sua tela.

Atenciosamente,
Gustavo.

Gustavo Gabbardo dos Reis

Mensagens : 19
Data de inscrição : 23/07/2020

Isabela Rotondaro gosta desta mensagem

Voltar ao Topo Ir em baixo

Problemas com a criação das Classes de Respostas Hidrológicas Empty Problemas com a criação das Classes de Respostas Hidrológicas

Mensagem  Isabela Rotondaro em Ter Set 15, 2020 9:34 pm

Olá Gustavo!

Eu abri o arquivo através da ferramenta "Bloco de Notas", e percebi que aparece apenas o valor "-9999", referente a células vazias, como você mesmo citou. Eu tentei localizar os demais valores (de 1 a 9), porém percebi que realmente não constam no arquivo.

Dessa forma, aparentemente o arquivo está vazio mesmo.

Como posso proceder?

Abraços.

Isabela Rotondaro

Mensagens : 4
Data de inscrição : 17/08/2020

Voltar ao Topo Ir em baixo

Problemas com a criação das Classes de Respostas Hidrológicas Empty Re: Problemas com a criação das Classes de Respostas Hidrológicas

Mensagem  Gustavo Gabbardo dos Reis em Sab Set 19, 2020 5:18 pm

Oi Isabela,

Fiz um teste aqui para verificar se a ferramenta estava funcionando. Não encontrei problemas ao fazer a extração, então acredito que seja algum arquivo que você está usando que não esteja correto.
Você selecionou a opção "copy spatial parameters from file" e indiciou o arquivo de raster (não o arquivo vetorial) das minibacias ?
O shapefile do arquivo Polygon Mask File que você está usando (o mesmo que vc usou para recortar o MDE) também está ok e devidamente salvo no seu diretório ?
O arquivo raster dos blocos de toda a américa do sul (HRUres.irst) foi baixado corretamente ? Ele também não está em branco ? (verifiquei aqui e ele apresenta 399,114 KB no meu diretório).

Att,
Gustavo.

Gustavo Gabbardo dos Reis

Mensagens : 19
Data de inscrição : 23/07/2020

Isabela Rotondaro gosta desta mensagem

Voltar ao Topo Ir em baixo

Problemas com a criação das Classes de Respostas Hidrológicas Empty Problemas com a criação das Classes de Respostas Hidrológicas

Mensagem  Isabela Rotondaro em Dom Set 20, 2020 10:14 pm

Boa noite Gustavo!

Bom, realizei o procedimento conforme indicado no manual. Eu selecionei a opção "copy spatial parameters from file", indicando o arquivo raster das minibacias. Utilizei o arquivo shapefile da máscara da bacia, o mesmo que utilizei para recortar a bacia (que por sinal deu certo). O arquivo raster da América do Sul foi baixado corretamente sim, inclusive, apresenta o mesmo tamanho que o seu, 399,144 KB.

Até aqui os procedimentos todos haviam dado certo! Não entendo o que pode ter acontecido.


Isabela Rotondaro

Mensagens : 4
Data de inscrição : 17/08/2020

Voltar ao Topo Ir em baixo

Problemas com a criação das Classes de Respostas Hidrológicas Empty Re: Problemas com a criação das Classes de Respostas Hidrológicas

Mensagem  Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum